3 questions / Various

Accueil Forums Main plugin support 3 questions / Various

15 sujets de 21 à 35 (sur un total de 35)
  • Auteur
    Messages
  • #419398
    LSLi
    Participant
    Cette réponse a été marquée comme privée.
    #419595
    Thomas Lartaud
    Admin bbPress

    Hi there,

    The error is in your theme, at this CSS line :
    .row{display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;-webkit-flex-wrap:wrap;-ms-flex-wrap:wrap;flex-wrap:wrap;margin-left:-.9375rem;margin-right:-.9375rem}
    If I remove this, everything works fine.

    You’ll need to contact your theme author and tell him that there is an issue on his theme because of the usage of flex properties on .row elements. I really don’t understand why your theme is coded with flexboxes. I don’t really see how it can be usefull on WordPress, till all flexboxes children will get their display property ignored. This is the worst choice for a theme development. I don’t use these properties, so I don’t know how to reset them. Whatever I enter, the slick slider keeps rendered as a flex item, which is why it’s not working. Your theme will affect any plugin on your site, and change the rendering, and change all the displays, just because of this line of code.

    Please ask your theme author a solution to get the .row flex children as a standard .row set as display: block instead of flex.

    He will understand that, but not sure he will give you a solution, till all the theme is made like that. Do not hesitate to tell me what he said.

    Regards.

    #419597
    Thomas Lartaud
    Admin bbPress

    If your theme author can’t do anything (that would be weird …), I’ll help you to remove the Slick initialization. You’ll get no slider for displaying the custom fields, but at least it may work. But the really best solution is to ask your theme author, how to not get the children affected by the flex container.

    Hope that helps.

    #429871
    LSLi
    Participant
    Cette réponse a été marquée comme privée.
    #430994
    Thomas Lartaud
    Admin bbPress
    Cette réponse a été marquée comme privée.
    #430996
    LSLi
    Participant
    Cette réponse a été marquée comme privée.
    #431470
    Thomas Lartaud
    Admin bbPress

    Hi,

    I know this is hard to get, but working with a theme from an author that “don’t want to help” won’t be easy.

    If your theme author cannot do anything for you, nor don’t want to help, I won’t be able to do anything.

    We know there is some incompatibility with our plugin. In fact, any plugin has some incompatibility with some others plugin. The best we can do is debugging out them one by one. That’s why a plugin or a theme without support is almost already dead.

    Now, I’m sorry to say that. This the absolute first time since WP Customer Area is alive I’m saying that, but you’ll need to choose between keeping a theme without support (and switch to another solution than WPCA), or say goodbye to your theme, and find a one that has active support and developed by an author that agrees to help you.

    Best regards.

    #431476
    Thomas Lartaud
    Admin bbPress

    Alternatively, don’t worry, you can still work with both, even if I don’t recommend it.

    You can disable the part that does not work.

    From our theme development documentation, you’ll be able to understand how our theme_support works.

    You can add this to the end of your functions.php file :

    add_theme_support('customer-area.library.jquery.slick', array('files'));

    This line of code will tell WPCA to disable inclusion of the Slick script which is not working with your theme. However, the HTML tags will be kept on the page but will just be hidden with some display: none; properties.

    You’ll then be able to customize this part by adding some custom CSS, and show it as you want.

    This will work. However, I cannot ensure you that your theme won’t cause any other issue with WPCA.

    Regards.

    #431482
    LSLi
    Participant
    Cette réponse a été marquée comme privée.
    #431509
    LSLi
    Participant
    Cette réponse a été marquée comme privée.
    #431524
    Thomas Lartaud
    Admin bbPress

    Hi,

    I fixed the issue for you. I added a new plugin to your site called WPCA-theme-compat.

    It is just removing the use of the Slick script that do not work with your theme, and I’ve added a CSS display: block properties to it so it can be shown.

    The display is really not the best. One again, BECAUSE OF YOUR THEME ! So please, don’t ask anything here about how the area is being displayed. Ask your theme author. I won’t help any more on this here because this is clearly out of our scope support. I’ve just helped here because I don’t want to leave you without a solution. But sincerely, you should think about what your theme author is (not) doing for you….

    For instance, in the above screenshot, you will also see that the area is smaller than the page’s width. Please, don’t ask me how to fix that. It’s 3000% your theme author’s job that decided to code the theme using flexboxes.

    slick-removed

    Best regards.

    Pièces jointes:
    #431530
    Thomas Lartaud
    Admin bbPress

    If someone else need to remove Slick from WPCA, this is how to do it using a plugin :

    <?php
    /*
    Plugin Name: WPCA Theme compat
    Plugin URI:
    Description: Removing WPCA Slick
    Version:     1.0.0
    Author:      Thomas Lartaud
    Author URI:  https://wp-customerarea.com
    License:     GPL2
    License URI: https://www.gnu.org/licenses/gpl-2.0.html
    */
    
    defined('ABSPATH') or die('Nope, not accessing this');
    
    /**
     * Remove Slick script inclusion
     */
    function custom_cuar_remove_slick()
    {
    	add_theme_support('customer-area.library.jquery.slick', array('files'));
    }
    add_action('init', 'custom_cuar_remove_slick', 15);
    
    /**
     * Show slick containers
     */
    function custom_cuar_show_slick_containers()
    {
    	$custom_css = "body.customer-area-active .cuar-css-wrapper .slick-slide {display:block;}";
    	wp_add_inline_style( 'cuar.frontend', $custom_css );
    }
    add_action('wp_enqueue_scripts', 'custom_cuar_show_slick_containers', 150);
    #431541
    Thomas Lartaud
    Admin bbPress

    Another tip for you :

    – Don’t use a theme, use a child theme (ask your theme author if there is one available, or just create one [check google])
    – Once your child theme is created, copy the theme page.php to a new file cuar.php that you need to create in your child theme folder. It will allow WPCA to use the pages templates from your theme instead of the single.php file (i think it can fix the smaller width issue).

    Regards.

    #432460
    LSLi
    Participant

    Hi Thomas,
    First of all, thank you very much for this solution, it works very well.

    The addition of the following code made it possible to have a good display:
    .single-cuar_private_file .page-main-content {width: 100%; }

    I’m going to see to use a child theme, but can you please tell me precisely what you add on your side, and on which file, so that I keep this site running by putting your code on the files of my theme child.
    Is all the code on page.php? Is this a page that you have added ?

    Thank you in advance for this finalization.

    #434348
    Thomas Lartaud
    Admin bbPress

    Hi,

    The only thing I have added is the plugin WPCA theme compat I added on your site which disable SlickJS.

    Regards.

15 sujets de 21 à 35 (sur un total de 35)
  • Vous devez être connecté pour répondre à ce sujet.